FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > VHDL

VHDL comp.lang.vhdl newsgroup / Usenet

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10-21-2003, 09:47 PM
Panic
Guest
 
Posts: n/a
Default Strange error in Quartus II 3.0

After searching for the source of an error for quite a long time, I've
decided that I need some help, and once again you guys drew the shortest
straw ;-)

I have a 8 bit DFF with output q[7..0]. This feeds the net
dff_inst23_out[7..0]. (The reason this net is given this name, was to see if
the error actually was located where I thought it was, since the original
error pointed to some temp net.) Both the DFF output and the net is 8 bits
wide, and still I get this error message:

Error: Net dff_inst23_out[6] cannot be assigned more than one value
Error: Net is fed by std_8bit_dff0:inst8|lpm_ff:lpm_ff_component|dffs[6]
Error: Net is fed by std_8bit_dff0:inst9|lpm_ff:lpm_ff_component|dffs[6]
Error: Net is fed by std_8bit_dff0:inst23|lpm_ff:lpm_ff_component|dffs[6]

This is repeated for each bit of dff_inst23_out.

Ok, so I have two other registers that feed this net, but they are not
connected! I understand that this is happening because the output of these
other registers are the same as the inst23 one, but hey, I've got more
registers like that, all over the place! So why is this happening to this
particular net?

I've taken a screenshot of the design in question, and my troublesome net is
the blue stub:
http://www.battlefield.no/bilder/inst23.gif

Any suggestions would be appreaciated!
Sincerely
-"Panic"


Reply With Quote
  #2 (permalink)  
Old 10-21-2003, 09:49 PM
Panic
Guest
 
Posts: n/a
Default Re: Strange error in Quartus II 3.0

Ooops. Should have been posted in comp.arch.fpga....

Sorry.


Reply With Quote
  #3 (permalink)  
Old 10-24-2003, 02:42 AM
Marc Guardiani
Guest
 
Posts: n/a
Default Re: Strange error in Quartus II 3.0

Make sure you don't have another net with the same name. Even if they
are not physically connected, they will be logically connected.

Panic wrote:
>
> Error: Net dff_inst23_out[6] cannot be assigned more than one value
> Error: Net is fed by std_8bit_dff0:inst8|lpm_ff:lpm_ff_component|dffs[6]
> Error: Net is fed by std_8bit_dff0:inst9|lpm_ff:lpm_ff_component|dffs[6]
> Error: Net is fed by std_8bit_dff0:inst23|lpm_ff:lpm_ff_component|dffs[6]
>
> This is repeated for each bit of dff_inst23_out.


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange XST error in ISE 6.3.02i rickman FPGA 9 11-02-2004 10:44 PM
strange error gilbert FPGA 0 03-07-2004 12:39 PM
Strange error in Quartus II 3.0 Panic FPGA 6 10-22-2003 06:46 PM


All times are GMT +1. The time now is 10:12 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved