FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-15-2007, 03:08 AM
Andrew FPGA
Guest
 
Posts: n/a
Default Xilinx Chipscope Pro in EDK system - ILA:how specify separate signalsfor data capture and triggering?

Hi,
This is an embarrassing question to be asking - how does one attach
signals from the edk design to the chipscope ILA? When I sit down at
my desk to debug with a benchtop logic analyser, the first thing I do
is attach the probes to the pcb - I kinda expected it would be simple
and straightforward with chipscope pro also?

I'm using EDK 9.1i, sp3. I used the debug->debug config menu and
selected an ILA. Its easy to select signals and add them to Trig0. But
if I want the trigger and data capture signals to be different, where
and how do I attach signals in my design to the data capture port on
the ILA?

(I have limited resources remaining on my FPGA and I only need a few
simple signals connected to the trigger input, but I want a wider
selection of signals captured in the trace buffer)

I tried manually editing the ILA component in the .mhs file, by adding
the entry below:

PORT DATA =
EthInterfaceTimestamp_0_rx_dv_falling_edge_r_to_ch ipscope_ila_0 &
EthInterfaceTimestamp_0_rx_dv_rising_edge_r_to_chi pscope_ila_0 &
EthInterfaceTimestamp_0_tx_en_falling_edge_r_to_ch ipscope_ila_0 &
EthInterfaceTimestamp_0_tx_en_rising_edge_r_to_chi pscope_ila_0 &
EthInterfaceTimestamp_0_timestamp_to_chipscope_ila _0

Which caused edk to crash...Is editing the .mhs file ok?

Regards
Andrew


Reply With Quote
  #2 (permalink)  
Old 11-15-2007, 08:48 PM
roger
Guest
 
Posts: n/a
Default Re: Xilinx Chipscope Pro in EDK system - ILA:how specify separatesignals for data capture and triggering?

On Nov 15, 4:08 am, Andrew FPGA <[email protected]> wrote:
> Hi,
> This is an embarrassing question to be asking - how does one attach
> signals from the edk design to the chipscope ILA? When I sit down at
> my desk to debug with a benchtop logic analyser, the first thing I do
> is attach the probes to the pcb - I kinda expected it would be simple
> and straightforward with chipscope pro also?
>
> I'm using EDK 9.1i, sp3. I used the debug->debug config menu and
> selected an ILA. Its easy to select signals and add them to Trig0. But
> if I want the trigger and data capture signals to be different, where
> and how do I attach signals in my design to the data capture port on
> the ILA?
>
> (I have limited resources remaining on my FPGA and I only need a few
> simple signals connected to the trigger input, but I want a wider
> selection of signals captured in the trace buffer)
>
> I tried manually editing the ILA component in the .mhs file, by adding
> the entry below:
>
> PORT DATA =
> EthInterfaceTimestamp_0_rx_dv_falling_edge_r_to_ch ipscope_ila_0 &
> EthInterfaceTimestamp_0_rx_dv_rising_edge_r_to_chi pscope_ila_0 &
> EthInterfaceTimestamp_0_tx_en_falling_edge_r_to_ch ipscope_ila_0 &
> EthInterfaceTimestamp_0_tx_en_rising_edge_r_to_chi pscope_ila_0 &
> EthInterfaceTimestamp_0_timestamp_to_chipscope_ila _0
>
> Which caused edk to crash...Is editing the .mhs file ok?
>
> Regards
> Andrew


Hi Andrew,

It is very straightforward, you have one data port and one trig port
on the chipscope IP in EDK. Then you have to configure the IP by right-
clicking the IP and choose configure IP. You have to set the data and
trigger port widths. You should only edit the mhs file if your'e
certain about the syntax.

Regards,
Roger
Reply With Quote
  #3 (permalink)  
Old 11-15-2007, 10:58 PM
Andrew FPGA
Guest
 
Posts: n/a
Default Re: Xilinx Chipscope Pro in EDK system - ILA:how specify separatesignals for data capture and triggering?

Hi Roger,
Thanks for the info, but following your suggestion does not appear to
be any different than going to the menu Debug->debug configuration and
selecting ila0.
Sure you can set the trigger port width and data width. You can also
add signals to the Trigger input. But how do I add signals to the DATA
ila input?
I can use the system assembly view with ports filter is see the ILA
ports. I can see the data port, but the connection drop down list only
allows me to connect one signal at a time. Of course I want to connect
several different signals to the Ila Data port but can't see how?

> It is very straightforward, you have one data port and one trig port
> on the chipscope IP in EDK.

Yes it describes this in the documentation, but it is quite unclear as
to how one connects signals in the design to the Data port.

> Then you have to configure the IP by right-
> clicking the IP and choose configure IP. You have to set the data and
> trigger port widths. You should only edit the mhs file if your'e
> certain about the syntax.

Yeah, and I don't know the syntax for the Data port, nor have I been
able to find it.


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
using system ACE for generic app data storage - file system intelligencerequired? Jeff Cunningham FPGA 1 03-13-2007 06:47 PM
Using Hyper Terminal to send& capture data Smith Verilog 3 07-03-2006 11:42 AM
Extending chipscope capture memory by using external async SRAM Jac Athow FPGA 1 11-18-2004 07:55 PM
Serial Data Capture Weddick FPGA 2 05-11-2004 04:40 AM


All times are GMT +1. The time now is 06:47 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved