FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-01-2005, 03:41 PM
ARRON
Guest
 
Posts: n/a
Default why can't i use opb_spi core in EDK6.3?

I have added the opb_spi core in my project,I can assure the opb_spi have been inserted in the project(because i can find the synthesise and implemention file of opb_spi).But i can't find any parameter about opb_spi in the xparameters.h,and can't the head file in the directory of PPC405_0/libsrc or PPC405_0/include, what is wrong?
Reply With Quote
  #2 (permalink)  
Old 06-01-2005, 04:29 PM
dexue
Guest
 
Posts: n/a
Default Re: why can't i use opb_spi core in EDK6.3?



ARRON wrote:
> I have added the opb_spi core in my project,I can assure the opb_spi have been inserted in the project(because i can find the synthesise and implemention file of opb_spi).But i can't find any parameter about opb_spi in the xparameters.h,and can't the head file in the directory of PPC405_0/libsrc or PPC405_0/include, what is wrong?


Sometimes if you manually add ipcores to .mhs file, EDK does not put
parameters to xparameters.h file. You have to use the Add/EDit Core GUI
to add ipcore correctly.

-James

Reply With Quote
  #3 (permalink)  
Old 06-01-2005, 05:44 PM
Duane Clark
Guest
 
Posts: n/a
Default Re: why can't i use opb_spi core in EDK6.3?

dexue wrote:
>
> ARRON wrote:
>
>>I have added the opb_spi core in my project,I can assure the opb_spi have been inserted in the project(because i can find the synthesise and implemention file of opb_spi).But i can't find any parameter about opb_spi in the xparameters.h,and can't the head file in the directory of PPC405_0/libsrc or PPC405_0/include, what is wrong?

>
>
> Sometimes if you manually add ipcores to .mhs file, EDK does not put
> parameters to xparameters.h file. You have to use the Add/EDit Core GUI
> to add ipcore correctly.
>


I'll just add that what goes into the xparameters.h file is determined
by the file system.mss in the base of your project. This is a plain text
file with very simple parameters. You can always add an entry to it for
your spi core.
Reply With Quote
  #4 (permalink)  
Old 06-02-2005, 03:18 AM
Benjamin J. Stassart
Guest
 
Posts: n/a
Default Re: why can't i use opb_spi core in EDK6.3?

The xparameters.h, other include files, and libraries are based on the
driver selected for that peripheral.

In XPS, select Project->Software Platform Settings (or double click on the
processor in the System tab) and assign a driver to the opb_spi. You can
select between none, spi, and generic. I would recommend selecting spi.

As Duane Clark pointed out you can also manually add the spi driver to your
[project name].mss file.

There is no problem with manually adding IPs to the .mhs file, but if you
want to use their driver one must also add it to the .mss file.

Tip: One can assign the default drivers to all the IP in the system by
selecting Project->Assign Default Drivers.

"ARRON" <[email protected]> wrote in message
news:[email protected]
> I have added the opb_spi core in my project,I can assure the opb_spi have

been inserted in the project(because i can find the synthesise and
implemention file of opb_spi).But i can't find any parameter about opb_spi
in the xparameters.h,and can't the head file in the directory of
PPC405_0/libsrc or PPC405_0/include, what is wrong?



Reply With Quote
  #5 (permalink)  
Old 06-02-2005, 04:46 AM
ARRON
Guest
 
Posts: n/a
Default Re: why can't i use opb_spi core in EDK6.3?

hello,everyone.I always build my project and compile it in EDK,but now i want to compile my project in gcc,who can tell me the process of compile the project step by step, thanks a lot!!!!
Reply With Quote
  #6 (permalink)  
Old 06-02-2005, 10:38 AM
ARRON
Guest
 
Posts: n/a
Default Re: why can't i use opb_spi core in EDK6.3?

Adding opb_spi through ADD/EDIT CORE is correct, and the opb_spi has drivers in the MSS file,which is 1.00.b, i am confused for this problem.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EDK6.2i - Error message during PlatGen after adding in HDL files to User IP core Philipp Grabher FPGA 1 02-04-2005 07:38 PM
DMA for PPC in Virtex-II Pro/EDK6.2 Jeffsen FPGA 0 11-14-2004 09:13 PM
EDK6.1 vs. EDK3.2 clarification Jon Masters FPGA 1 02-18-2004 06:28 PM


All times are GMT +1. The time now is 01:38 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved