FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-04-2007, 10:48 AM
roger
Guest
 
Posts: n/a
Default Problem with PHY clocks on Spartan 3E Starter Kit

Hi,

I am designing a ethernet block using the Spartan 3E Starter Kit. The
design will be using the RX and TX clock provided by the SMSC PHY on
FPGA pins T7 and V3 on the Spartan 3E Starter Kit. I have problems
getting the design to work and when I started to look for errors I
found that the RX clock from the PHY doesn't seem to be possible to
use as a clock.

I made a simple counter which flashes a led in 2 Hz using first the TX
clock from the PHY as the clock input and then the RX clock as the
clock input. When I'm using the TX clock everything works fine and
when I'm using the RX clock I get no activity at all. I have verified
that I have a clock output from the PHY using an oscilloscope.

If I instead run the counter on the 50MHz clock and sample the RX or
TX clock and increment the counter when an change on the RX or TX
clock signal has occured it works fine using any of the input clocks
from the PHY.

One could suspect some problems with the input buffers in the FPGA but
since it works using the TX clock I cant see that it is a problem in
the FPGA. It is a very confusing problem, can you give me some help
what I am doing wrong?

Reply With Quote
  #2 (permalink)  
Old 04-10-2007, 08:42 AM
Eric Smith
Guest
 
Posts: n/a
Default Re: Problem with PHY clocks on Spartan 3E Starter Kit

"roger" <[email protected]> writes:
> I made a simple counter which flashes a led in 2 Hz using first the TX
> clock from the PHY as the clock input and then the RX clock as the
> clock input. When I'm using the TX clock everything works fine and
> when I'm using the RX clock I get no activity at all. I have verified
> that I have a clock output from the PHY using an oscilloscope.


Doesn't the RX clock only appear while a frame is being received?
That was how many of the lower-speed PHY interfaces worked, but I'm not
sure about MII.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spartan 3 Starter Kit .mcs upload problem Jürgen Böhm FPGA 1 11-21-2006 07:01 PM
Potential problem w/EDK's Microblaze and the Spartan-3E Starter Kit? [email protected] FPGA 5 10-23-2006 11:19 AM
Spartan-3 starter kit strange problem jmariano FPGA 2 06-22-2006 01:43 PM
Digilent Spartan-3 Starter Kit w/ JTAG-USB Problem/Solution Scott M. Kroll FPGA 14 03-16-2006 03:58 AM
To Xilinx: Problem with Digilent Spartan III Starter Kit Documentation Rob Gaddi FPGA 2 05-13-2005 06:46 PM


All times are GMT +1. The time now is 05:51 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved