FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-09-2005, 01:07 AM
Nitesh
Guest
 
Posts: n/a
Default pci ml310 board

Hello,
I am using xilinx ml310 board. Now I want to use networking feature on
the
board
and hence I have to enable the "ENABLE PCI" option in the
configuration of
kernel which I am trying to load onto the ppc.
Now once I enable the enable pci option what happens is that the kernel
during
the make zImage command execution asks for the following parameters
which are
not present in the xparameters_ml300.h file

`XPAR_PCI_0_IO_BASEADDR'
`XPAR_PCI_0_CONFIG_ADDR'
`XPAR_PCI_0_LCONFIG_ADDR'

All these parameters I believe get added in xparamters_ml300.h file. If
I am
using ml300 board and I add the pci module in the bsp then they get
added.
However the ml310 board has a different architecture and hence the pci
bridge
parameters get added instead of the above.
How do I get around this problem.If I disable the pci then I can
compile the
kernel succesfully. But to use the networking feature I believe I have
to use
pci.
Has anyone come across this problem?
Has anyone successfully compiled linux kernel with pci support on
ml310?
Thanks,
Nitesh

Reply With Quote
  #2 (permalink)  
Old 11-09-2005, 01:21 AM
Peter Ryser
Guest
 
Posts: n/a
Default Re: pci ml310 board

Please visit the ML310 web pages at http://www.xilinx.com/ml310. Under
Documentation and reference designs you will find a section of
information on how to build a Linux system including PCI. One of these
documents is a "Tutorial on how to configure and re-create the Linux
kernel for the PCI design using XPS and MVL 3.1 Pro."
(http://www.xilinx.com/products/board...j_creation.pdf)

Cheers,
- Peter


Nitesh wrote:
> Hello,
> I am using xilinx ml310 board. Now I want to use networking feature on
> the
> board
> and hence I have to enable the "ENABLE PCI" option in the
> configuration of
> kernel which I am trying to load onto the ppc.
> Now once I enable the enable pci option what happens is that the kernel
> during
> the make zImage command execution asks for the following parameters
> which are
> not present in the xparameters_ml300.h file
>
> `XPAR_PCI_0_IO_BASEADDR'
> `XPAR_PCI_0_CONFIG_ADDR'
> `XPAR_PCI_0_LCONFIG_ADDR'
>
> All these parameters I believe get added in xparamters_ml300.h file. If
> I am
> using ml300 board and I add the pci module in the bsp then they get
> added.
> However the ml310 board has a different architecture and hence the pci
> bridge
> parameters get added instead of the above.
> How do I get around this problem.If I disable the pci then I can
> compile the
> kernel succesfully. But to use the networking feature I believe I have
> to use
> pci.
> Has anyone come across this problem?
> Has anyone successfully compiled linux kernel with pci support on
> ml310?
> Thanks,
> Nitesh
>


Reply With Quote
  #3 (permalink)  
Old 11-09-2005, 05:14 PM
Guest
 
Posts: n/a
Default Re: pci ml310 board

Which kernel are u using...I have been trying to get a custom kernel on
the ml-310 since many months and still I am not successful...Anyways I
ported 2.4 and 2.6 without PCI support , but with PCI, I could compile
the kernel but I couldnt get it to boot...

--
Parag

Reply With Quote
  #4 (permalink)  
Old 11-09-2005, 06:24 PM
Peter Ryser
Guest
 
Posts: n/a
Default Re: pci ml310 board

I recommend to start with the MontaVista Linux Preview Kit for the
ML300. It can be downloaded from http://www.mvista.com/previewkit free
of charge. The web pages I pointed you to are based on the MontaVista
Linux 3.1 Pro edition. The previewkit is the same as far as the kernel
goes but does not have the advanced development tools (Eclipse, etc).

- Peter


[email protected] wrote:
> Which kernel are u using...I have been trying to get a custom kernel on
> the ml-310 since many months and still I am not successful...Anyways I
> ported 2.4 and 2.6 without PCI support , but with PCI, I could compile
> the kernel but I couldnt get it to boot...
>
> --
> Parag
>


Reply With Quote
  #5 (permalink)  
Old 11-10-2005, 12:55 AM
Nitesh
Guest
 
Posts: n/a
Default Re: pci ml310 board

Hello,
I am able to compile the kernel succesfully.
Now I have one more problem. I load the bit file and download the
kernel.
The following screen appears on my minicom and then goes dead.
Enter Desired System ACE CF Configuration <0-7>.
0: ACE-loader.
1: Linux w/PCI.
2: VxWorks w/PCI.
3: QNX Demo.
4: Linux EDK Base Build.
5: VxWorks EDK Base Build.
6: User Configuration A.
7: User Configuration B.


Select:
loaded at: 00400000 008CB1E0
board data at: 008C8138 008C8150
relocated to: 00405308 00405320
zimage at: 00405813 004DE42A
initrd at: 004DF000 008C7382
avail ram: 008CC000 10000000


Linux/PPC load: console=ttyS0,9600 root=/dev/xsysace/disc0/part2 rw
Uncompressing Linux...done.
Now booting the kernel




It gets stuck on booting the kernel.
Any suggestions....
Thanks
Nitesh

Reply With Quote
  #6 (permalink)  
Old 11-10-2005, 02:03 AM
Nitesh
Guest
 
Posts: n/a
Default Re: pci ml310 board

Hi Parag ,
I am using 2.4.26 kernel.
I am also trying it with the monta vista preview kit as told by peter.
I will try the pci example with the montavista kernel.
For the pci parameters eroor what I did was I copied the parameters
from the xparameters_ml300.h file patch given by Andrei Konovalov on
http://galileo.gamepoint.com.au/pub/...-support.patch

Nitesh

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PCI on ML310 Xilinx board Sven Gowal FPGA 4 09-08-2005 11:10 AM
About the ethernet access on the ML310 board! more FPGA 0 03-25-2005 09:01 AM
About the usb access in board ML310! more FPGA 3 03-25-2005 09:01 AM
Xilinx ML310 board's IO Wing Fong Wong FPGA 2 03-04-2005 09:08 AM
Help using the ML310 developement board jack lalo FPGA 0 02-20-2005 06:25 AM


All times are GMT +1. The time now is 02:05 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved