FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-27-2006, 05:30 AM
Yaseen Zaidi
Guest
 
Posts: n/a
Default Modelsim Simulation

I have a mismatch in Modelsim behavioral simulations using 1) VHDL
testbench in ISE and 2) manual entry of stimuli.

While the vector inputs are same in time and values in both cases, the
output, however, is different. The manual simulation seems working as
designed but the testbench based simulation has a delayed output and
the current state of FSM is stuck to certain state.

This is the first time I have encountered this problem, otherwise I
have been consistently getting same results whether I manually simulate
the design or use a testbench. I am quite clueless here. I don't know
whether the problem is attributed to the Modelsim or the design itself
since Modelsim gives two different results on same source file, the
mode of simulation is different though.

Regards,

YZ

Reply With Quote
  #2 (permalink)  
Old 04-27-2006, 06:39 AM
Abs
Guest
 
Posts: n/a
Default Re: Modelsim Simulation

hey Yaseen;
i dont think so. modelsim and ur testbench should produce same results.
modelsim is basically the simulation tool. check at the clock, input
values, control signals and since you have to force values in modelsim,
check out if u doing it correctly. the timing is the same.

Cheers
Abbs

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Simulation problems with EDK 7.1.02i and ModelSim SE 6.1a Brian C. Van Essen FPGA 6 09-07-2005 04:14 PM
Modelsim simulation question Marco FPGA 0 09-02-2005 03:38 PM
Simulation error with ModelSim cedric FPGA 1 01-20-2005 07:04 PM
EDK 3.2 and modelsim ppc simulation Mancini Stephane FPGA 2 09-13-2004 02:20 PM
Post Simulation in ModelSim 5.4d Mehmood Verilog 1 10-17-2003 12:07 PM


All times are GMT +1. The time now is 06:22 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved