FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-30-2006, 11:31 AM
GaLaKtIkUs™
Guest
 
Posts: n/a
Default ML403 ZBT SRAM

Hi all, I'm trying to develop a controller for the ZBT SRAM present on
the ML403 board. When I make a post P&R simulation (using manufacturer
verilog models of the memory) all is ok. But when I make on board tests
nothing works.
I even added a DCM for making board level clock deskewing.
Please help. I would like to have a small basic example of a
controller.

Cheers

Reply With Quote
  #2 (permalink)  
Old 05-01-2006, 11:33 PM
Brad Smallridge
Guest
 
Posts: n/a
Default Re: ML403 ZBT SRAM

I have a ML402 ZBT RAM running, however, how can I help you? You do not
describe your problem.

Brad Smallridge
AiVision dot com


Reply With Quote
  #3 (permalink)  
Old 05-02-2006, 08:57 AM
GaLaKtIkUs™
Guest
 
Posts: n/a
Default Re: ML403 ZBT SRAM

The problem is the following: I write some thing and when I read back I
get 32'd0.
When I make a post Place and route simulation all is ok.

Reply With Quote
  #4 (permalink)  
Old 05-03-2006, 03:36 PM
Brad Smallridge
Guest
 
Posts: n/a
Default Re: ML403 ZBT SRAM

What are you writing out? And do you delay the write data?



Reply With Quote
  #5 (permalink)  
Old 05-04-2006, 09:28 AM
GaLaKtIkUs™
Guest
 
Posts: n/a
Default Re: ML403 ZBT SRAM


Brad Smallridge wrote:
> What are you writing out? And do you delay the write data?


Hi Brad, Yes I delay the data. I solved the problem. For testing my
controller on hardware I used RS232 controller + ChipScope VIO: I send
some data from the PC, than using a VIO button I send data from the
RS232 RX FIFO to memory and than I read back the memory and send to PC
through RS232 TX.
The problem was that there were latencies on RS232 controllers and I
got wrong data.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux on ml403 jfh FPGA 6 03-31-2006 07:23 AM
porting linux on ml403 ramesh FPGA 13 02-08-2006 11:51 PM
Xilinx ML403 Error 1 LED [email protected] FPGA 4 11-02-2005 07:30 AM
Re: Xilinx ML403 Ed McGettigan FPGA 7 09-19-2005 09:18 PM
Control asynchronous SRAM like synchronous SRAM Michael Dreschmann FPGA 3 05-30-2005 09:24 PM


All times are GMT +1. The time now is 04:07 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved