FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05-29-2006, 04:59 PM
bjzhangwn
Guest
 
Posts: n/a
Default hard disk drivers problem

I am writing a interface about the ata interface but I have a problem
that the dma request signal is sometimes always high when power up,and
the hardware reset didn't work.So I don't have idea that what is the
problem.Also I try the samsung hard disk drivers,and the hardware reset
can reset the dma request signal to '0'!

Reply With Quote
  #2 (permalink)  
Old 05-29-2006, 05:21 PM
dp
Guest
 
Posts: n/a
Default Re: hard disk drivers problem

bjzhangwn wrote:
> I am writing a interface about the ata interface but I have a problem
> that the dma request signal is sometimes always high when power up,and
> the hardware reset didn't work.So I don't have idea that what is the
> problem.Also I try the samsung hard disk drivers,and the hardware reset
> can reset the dma request signal to '0'!


If by "hardware reset" you mean the reset signal on the ATA interace,
don't expect too much of it. The name is misleading, it does nothing
near what a power cycling reset will do - and it may vary between
vendors, especially when it comes to DMA and ATAPI combined
(fortunately, ATAPI provides fast transfer mechanisms in PIO mode...).

Dimiter

------------------------------------------------------
Dimiter Popoff Transgalactic Instruments

http://www.tgi-sci.com
------------------------------------------------------

Reply With Quote
  #3 (permalink)  
Old 05-30-2006, 01:18 PM
Michael Sch÷berl
Guest
 
Posts: n/a
Default Re: hard disk drivers problem

bjzhangwn schrieb:
> I am writing a interface about the ata interface but I have a problem
> that the dma request signal is sometimes always high when power up,and
> the hardware reset didn't work.


check your power-up sequence ...
the drive should go to a ready-state after delay and status-polling.
The procedure from the sepc just works fine for me and I never had an
issue with *that* ...


bye,
Michael
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with multiple constant drivers Carlos Barberis Verilog 1 11-04-2008 03:20 PM
hard disk drivers controller bjzhangwn Verilog 1 04-27-2006 08:34 AM
Problem in using Hard Macros in Xilinx ISE 7.1 Love Singhal FPGA 0 08-22-2005 10:12 PM
Soft CPU vs Hard CPU's teen FPGA 15 04-21-2005 03:50 PM


All times are GMT +1. The time now is 12:58 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved