FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-21-2007, 07:17 AM
Guest
 
Posts: n/a
Default An error occured while using Dual Port Block Memory

Hi!

I am using Dual Port Block Memory in Virtex-II, V8.2. During
simulation in Modelsim, i have encountered an error that reports to me
is:

$recovery(posedge clk B: .... ps, posedge clk A &&&
collision_posa_posb: ... ns, 1ns);

How can i cater this issue and how can i remove this error in my
simulation???

Regards
Rai
Reply With Quote
  #2 (permalink)  
Old 11-21-2007, 12:55 PM
Joseph Samson
Guest
 
Posts: n/a
Default Re: An error occured while using Dual Port Block Memory

[email protected] wrote:
> Hi!
>
> I am using Dual Port Block Memory in Virtex-II, V8.2. During
> simulation in Modelsim, i have encountered an error that reports to me
> is:
>
> $recovery(posedge clk B: .... ps, posedge clk A &&&
> collision_posa_posb: ... ns, 1ns);
>
> How can i cater this issue and how can i remove this error in my
> simulation???


What have you tried and and why didn't it work?


Here's what I did:

1. Google "verilog $recovery"

2. Read the first citation
<http://toolbox.xilinx.com/docsan/xilinx5/data/docs/sim/sim0066_10.html>

---
Joe Samson
Pixel Velocity
Reply With Quote
  #3 (permalink)  
Old 11-29-2007, 04:32 AM
RAI
Guest
 
Posts: n/a
Default Re: An error occured while using Dual Port Block Memory

On Nov 21, 4:55 am, Joseph Samson <[email protected]> wrote:
> [email protected] wrote:
> > Hi!

>
> > I am using Dual Port Block Memory in Virtex-II, V8.2. During
> > simulation in Modelsim, i have encountered an error that reports to me
> > is:

>
> > $recovery(posedge clk B: .... ps, posedge clk A &&&
> > collision_posa_posb: ... ns, 1ns);

>
> > How can i cater this issue and how can i remove this error in my
> > simulation???

>
> What have you tried and and why didn't it work?
>
> Here's what I did:
>
> 1. Google "verilog $recovery"
>
> 2. Read the first citation
> <http://toolbox.xilinx.com/docsan/xilinx5/data/docs/sim/sim0066_10.html>
>
> ---
> Joe Samson
> Pixel Velocity


hi sir!

thnx for your anticipation...........i am using dual port memory to
receive data from camera and pass it onto DSP..........and during
simulation in ModelSim there is an error like:

# ** Error :C:/Xilinx/Verilog/mti_se/XilinxCoreLib_ver/
XilinxCoreLib_ver_source.v(27060):$recovery(posedg e clk B: .... ps,
posedge clk A &&& collision_posa_posb: ... ns, 1ns);
# Time ... ps Iteration : 2 Instance/tb/dsp_inst0/memory_dp_inst0/inst

and thats error repeated after every some time period delay and
remained at the end of simulation...........plz guide me how can i get
through from this error???

Regards

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
dual port memory from single port RAM. vlsi_learner FPGA 9 04-20-2007 03:44 AM
Dual Port Block RAM Inference Yaseen Zaidi FPGA 0 02-14-2006 06:45 AM
true dual port memory v/s simple dual port memory [email protected] FPGA 10 05-17-2005 08:40 AM
Inferring Dual Port Block RAM Tom Hawkins FPGA 2 11-14-2003 08:47 PM


All times are GMT +1. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved