FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-12-2007, 12:22 PM
Pasacco
Guest
 
Posts: n/a
Default EDK 8.2 tool : simulator set up

Dear

I need to simulate my EDK (8.2) project.


Simulator is Modelsim SE 6.1c.


I did following steps:


-------------------------------------------
In order to compile COMPXLIB,


I used the EDK simulation library compilation wizard


Project -> Project options -> HDL and Simulation -> Simulation
library
path


EDK library = C:/EDK/EDK_LIB
Xilinx library = C:/Xilinx/Xilinx_LIB
-------------------------------------------


However, I could not proceed, because of the message "Modelsim is not
found. Please ensure that the simulator is correctly installed and/or
necessary environment settings are available".


Could anyone tell me "how to set up the environment" (or, how to
points to the location of the simulator)? in EDK 8.2 ?


Thank you in advance

Reply With Quote
  #2 (permalink)  
Old 11-12-2007, 04:40 PM
John McCaskill
Guest
 
Posts: n/a
Default Re: EDK 8.2 tool : simulator set up

On Nov 12, 6:22 am, Pasacco <[email protected]> wrote:
> Dear
>
> I need to simulate my EDK (8.2) project.
>
> Simulator is Modelsim SE 6.1c.
>
> I did following steps:
>
> -------------------------------------------
> In order to compile COMPXLIB,
>
> I used the EDK simulation library compilation wizard
>
> Project -> Project options -> HDL and Simulation -> Simulation
> library
> path
>
> EDK library = C:/EDK/EDK_LIB
> Xilinx library = C:/Xilinx/Xilinx_LIB
> -------------------------------------------
>
> However, I could not proceed, because of the message "Modelsim is not
> found. Please ensure that the simulator is correctly installed and/or
> necessary environment settings are available".
>
> Could anyone tell me "how to set up the environment" (or, how to
> points to the location of the simulator)? in EDK 8.2 ?
>
> Thank you in advance


It sounds like the environment variable MODEL_TECH is not set. I
believe that the ModelSim install program should have set this for
you. Look in your environment variables to see if it is set. Also, can
you already run ModelSim outside of EDK?


EDK has help information that walks you through what you need to do to
get set up for simulation.

In EDK, go to:

Help->Help Topics->Procedures for Embedded Processor Design->
Simulation

This will tell you what to do to get setup, including how to set
environment variables.

Regards,

John McCaskill,
www.fastertechnology.com

Reply With Quote
  #3 (permalink)  
Old 11-13-2007, 07:02 PM
Pasacco
Guest
 
Posts: n/a
Default Re: EDK 8.2 tool : simulator set up

Now simulation models and compile script are generated.
Thank you for your help.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BFM and ISE simulator Fizzy FPGA 0 05-02-2006 01:04 AM
BFM and ISE simulator Fizzy FPGA 0 05-02-2006 01:04 AM
ISE Simulator Brad Smallridge FPGA 3 02-09-2006 12:28 AM
New Verilog Simulator [email protected] Verilog 8 12-22-2005 02:01 AM
Why Xilinx ChipScope (or similar FPGA OCI tool) is a *MUST* Have tool Antti Lukats FPGA 13 11-10-2004 04:06 AM


All times are GMT +1. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved