FPGA Central - World's 1st FPGA / CPLD Portal

FPGA Central

World's 1st FPGA Portal

 

Go Back   FPGA Groups > NewsGroup > FPGA

FPGA comp.arch.fpga newsgroup (usenet)

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07-27-2005, 08:19 PM
Tim Verstraete
Guest
 
Posts: n/a
Default chipscope/impact Virtex4 problem

Hey all,

I just made a V4 pcb and wanted to configure the FPGA through impact => this
works fine, so it says that the done pin goes high and everything is ok but
the code will not run because the GHIGH_B stays low ... but when i configure
the fpga through chipscope everything works, the GHIGH_B goes high and the
vhdl is working ... how come???

i thought they both used the same process/dll/program to configure the
fpga?? i think it has something to do with the properties of the impact
program ...

thanks in advance,

kind regards,

Tim Verstraete


Reply With Quote
  #2 (permalink)  
Old 07-27-2005, 08:34 PM
Antti Lukats
Guest
 
Posts: n/a
Default Re: chipscope/impact Virtex4 problem

"Tim Verstraete" <[email protected]> schrieb im Newsbeitrag
news:[email protected]
> Hey all,
>
> I just made a V4 pcb and wanted to configure the FPGA through impact =>

this
> works fine, so it says that the done pin goes high and everything is ok

but
> the code will not run because the GHIGH_B stays low ... but when i

configure
> the fpga through chipscope everything works, the GHIGH_B goes high and the
> vhdl is working ... how come???
>
> i thought they both used the same process/dll/program to configure the
> fpga?? i think it has something to do with the properties of the impact
> program ...
>
> thanks in advance,
>
> kind regards,
>
> Tim Verstraete
>
>


No. The configuration has been a problem at all times there is always some
combination of software and cables that work and some that do not. Some
times impact works and chipscope not. Sometimes chipscope does and impact
not. sometimes cable IV does not work and self made cable does. etc etc etc.

A complete mess.

for V4 check the early silicon errata about JTAG maybe it applies to your
chip, I think not but who knows. Hm what V4 are you using? I can add support
for it into our JTAG frequence meter application, it includes config support
for V4, then you could see if our software works better than impact. in the
current public online version I think only LX25 is supported but we could
easily add your FPGA device to the supported list just to see if it would
configure

Antti







Reply With Quote
  #3 (permalink)  
Old 07-28-2005, 04:01 AM
Jim Wu
Guest
 
Posts: n/a
Default Re: chipscope/impact Virtex4 problem

If you're using 7.1.03i, you may want to take a look at AR 21694:
http://tinyurl.com/atxwr

Jim

"Tim Verstraete" <[email protected]> wrote in message
news:[email protected]
> Hey all,
>
> I just made a V4 pcb and wanted to configure the FPGA through impact =>

this
> works fine, so it says that the done pin goes high and everything is ok

but
> the code will not run because the GHIGH_B stays low ... but when i

configure
> the fpga through chipscope everything works, the GHIGH_B goes high and the
> vhdl is working ... how come???
>
> i thought they both used the same process/dll/program to configure the
> fpga?? i think it has something to do with the properties of the impact
> program ...
>
> thanks in advance,
>
> kind regards,
>
> Tim Verstraete
>
>



Reply With Quote
  #4 (permalink)  
Old 07-28-2005, 11:10 AM
Tim Verstraete
Guest
 
Posts: n/a
Default Re: chipscope/impact Virtex4 problem

Hey, I'm using a V4SX55-FF1148 ... an no, the errata doesn't mention
anything about the configuration ...

kind regards,

Tim Verstraete

Antti Lukats schreef:
> "Tim Verstraete" <[email protected]> schrieb im Newsbeitrag
> news:[email protected]
> > Hey all,
> >
> > I just made a V4 pcb and wanted to configure the FPGA through impact =>

> this
> > works fine, so it says that the done pin goes high and everything is ok

> but
> > the code will not run because the GHIGH_B stays low ... but when i

> configure
> > the fpga through chipscope everything works, the GHIGH_B goes high and the
> > vhdl is working ... how come???
> >
> > i thought they both used the same process/dll/program to configure the
> > fpga?? i think it has something to do with the properties of the impact
> > program ...
> >
> > thanks in advance,
> >
> > kind regards,
> >
> > Tim Verstraete
> >
> >

>
> No. The configuration has been a problem at all times there is always some
> combination of software and cables that work and some that do not. Some
> times impact works and chipscope not. Sometimes chipscope does and impact
> not. sometimes cable IV does not work and self made cable does. etc etc etc.
>
> A complete mess.
>
> for V4 check the early silicon errata about JTAG maybe it applies to your
> chip, I think not but who knows. Hm what V4 are you using? I can add support
> for it into our JTAG frequence meter application, it includes config support
> for V4, then you could see if our software works better than impact. in the
> current public online version I think only LX25 is supported but we could
> easily add your FPGA device to the supported list just to see if it would
> configure
>
> Antti


Reply With Quote
  #5 (permalink)  
Old 07-28-2005, 12:16 PM
Tim Verstraete
Guest
 
Posts: n/a
Default Re: chipscope/impact Virtex4 problem

idd, this patch has solved the virtex4 configuration problem ... i
really don't know how i could overlook this AR? Thank you very much
anyway ...

kind regards,

Tim Verstraete

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LVDS problem/chipscope VIRTEX4 Yttrium FPGA 0 07-26-2005 07:17 PM
Chipscope problem [email protected] FPGA 0 06-23-2005 03:21 PM
Virtex4 Block Ram : ISE6.3 Problem Luke Darnell FPGA 2 05-23-2005 04:32 PM
Chipscope and Virtex4 LX25 ES John Williams FPGA 1 03-23-2005 07:44 AM
chipscope pro problem (par) Yttrium FPGA 19 11-11-2004 08:20 PM


All times are GMT +1. The time now is 12:12 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright 2008 @ FPGA Central. All rights reserved