View Single Post
  #8 (permalink)  
Old 11-16-2007, 03:35 AM
Guest
 
Posts: n/a
Default Re: synopsys translate_off

You still are not adding the Library stuff when you are calling "vcom"

vcom -L XILINXCORELIB_VER -L UNISIM work.testbench

Hope this helps.

-- parag

On Nov 15, 12:27 pm, Pasacco <[email protected]> wrote:
> Dear
> I could not resove this problem.
>
> UNISIM and XILINXCORELIB are properly mapped to Modelsim.
>
> The thing is that
>
> The VHDL files "in Pcore directory" contain following:
> (BRAMs are instantiated in the VHDL.)
>
> --------------------------------------
> -- pragma translate_off
> library VIRTEX2;
> use VIRTEX2.all;
> -- pragma translate_on
> --------------------------------------
>
> When I try "do system.do", error occurred "Virtex2 library not found".
>
> When I comment the "Virtex2 library declaration" and I try "do
> system.do",
> no error and no warning occurred.
>
> --------------------------------------
> -- pragma translate_off
> --library VIRTEX2;
> --use VIRTEX2.all;
> -- pragma translate_on
> --------------------------------------
>
> Problem is that
>
> When I try "vcom -work work testbench.vhd", then following warning
> occurs.
>
> -----------------------
> Warning: Component instance "ramx32 : ramb16_s36_s36" is not bound.
> -----------------------
>
> This means that BRAM block is disappeared.
>
> As a result, I do not see any signal toggling in the waveform in
> Modelsim.
>
> My question is that
>
> What does the following mean?
> How can we find the library "VIRTEX2" and map?
> --------------------------------------
> -- pragma translate_off
> library VIRTEX2;
> use VIRTEX2.all;
> -- pragma translate_on
> --------------------------------------
>
> Thank you for reply in advance.






Reply With Quote